You are not logged in.



  • "Knarf" is male
  • "Knarf" started this thread

Posts: 1

Date of registration: Apr 23rd 2010

Location: Belgium

Occupation: Software Consultant

Hobbies: Women, movies, bicycling, software

  • Send private message


Friday, April 23rd 2010, 12:21pm

EXE won't run

I created a small project to view Jasper Reports.

When I run it from the Jabaco IDE, everything works fine.

When I run it as a generated exe, I see the following debug info in the console :

How can I resolve this ?

Thanks ! Frank (Belgium)

Exception in thread "main" java.lang.SecurityException: Invalid signature file digest for Manifest main attributes
at Source)
at Source)
at java.util.jar.JarVerifier.processEntry(Unknown Source)
at java.util.jar.JarVerifier.update(Unknown Source)
at java.util.jar.JarFile.initializeVerifier(Unknown Source)
at java.util.jar.JarFile.getInputStream(Unknown Source)
at sun.misc.URLClassPath$JarLoader$2.getInputStream(Unknown Source)
at sun.misc.Resource.cachedInputStream(Unknown Source)
at sun.misc.Resource.getByteBuffer(Unknown Source)
at Source)
at$000(Unknown Source)
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: Module1. Program will exit.
Frank - Belgium



  • "A1880" is male

Posts: 500

Date of registration: Jan 1st 2009

Location: Hanover, Germany

Occupation: Software Engineer

Hobbies: Hilbert Curves

  • Send private message


Friday, April 23rd 2010, 2:03pm

The Exe is just a self-extracting Jar archive which unpacks itself in %TEMP% and then executes "java -jar xyz.jar".
To pin down the problem you could compile your project into a Jar file rather than in an exe file.
Select filetype "Jar File" in the "File/Make Project" dialog.
If the resulting Jar file is runnable, the problem is due to the unpacking step.

You could rename the Jar into and unpack the contents to look at the Manifest file.

Have you changes something in your Module1? Your "main()" method might have a problem.



Rate this thread
WoltLab Burning Board