Jabaco IDE Description


This article descripes the usage and the parts of the Jabaco IDE.

Contents

Generally description

The term IDE is commonly used in the programming world to describe the interface and environment that we use to create our applications. It is called integrated because we can access virtually all of the development tools that we need from one screen called an interface. The IDE is also commonly referred to as the design environment, or the program.

Component description

The Jabaco / BASIC IDE is designed to maximize programmer productivity by providing tightly-knit components with similar user interfaces.

New Project Dialog

The "New Project Dialog" is shown at the startup of Jabaco. The dialog offers you several methods to start your project:

Create a new project with a templates

Icon Name Description
Image:SDIApplication.png SDI Application Create single document interface template. View Example.
Image:MDIApplication.png MDI Application Create multiple document interface template. View Example.
Image:AppletIcon.png Applet Create a Java Applet template. View Example.
Image:Console.png Console Application Create a console application template. View Example.
Image:ClassIcon.png Class Library Create a new Jabaco or Java class. View Example.

Recent projects

Switch to the 'Recent'-Tab will show you the last projects you have saved with Jabaco.

Existing projects

Select a JBP-file to open an existing Jabaco-project, or select a VBP-file to open an existing VB6-project and convert it to Jabaco.

Menu Bar

File-Menu

Item Shortcut Description
New Project Ctrl + N Create a new project
Open Project Ctrl + O Open an existing project
Save Project Ctrl + S Save project
Save Project As   Save project to specific folder
Close Project   Close project and set the IDE in startup-mode
Make Project   Compile the project to binary (exe or jar-file)
Exit ALT+Q Close the IDE

Edit-Menu

Item Shortcut Description
Undo CTRL+Z ?
Redo CTRL+Y ?
Cut CTRL+X ?
Copy CTRL+C ?
Paste CTRL+V ?
Delete   ?
Print CTRL+P ?
Find CTRL+F ?
Find Next F3 ?
Replace CTRL+H ?

Project-Menu

Item Shortcut Description
Start F5 ?
Start With Full Compile F6 ?
Break CTRL+PAUSE ?
End ?
Singlestep F8 ?
Procedurestep F& ?
Blockstep F9 ?
Step Return F4 ?
Show Stack Trace CTRL+L ?
Toggle Breakpoint CTRL+B ?
Toggle Bookmark F11 ?
GotoFlag F12 ?
References(Classpath) F1 ?

Language-Menu

Item Shortcut Description
Generic   Select your language; How to define a new language.


Help-Menu

Item Shortcut Description
Homepage   http://www.jabaco.org
Community   http://www.jabaco.org/board
Update Jabaco   Force autoupdate. Goto detailed definition.
Update Jabaco   ?
Info   ?




Toolbar

Image:ToolbarDescSmall.png

Itemname Description
New Project  ?
Open Project  ?
Save Project  ?
Copy  ?
Paste  ?
Print  ?
Find  ?
Undo  ?
Redo  ?
Start  ?
Switch to Bookmark  ?
Add Bookmark  ?
Remove Bookmark  ?
Comment Block  ?
Uncomment Block  ?
Next Page  ?
Last Page  ?

Project Explorer

The Project-Explorer

Source Editor

Form Designer

Add File

Icon Description
Form ?
MDI-Form ?
MDI-Child ?
User Control ?
Module ?
Class Module ?
Interface ?
Resource ?

Properties Window

xxxxxx

Form Designer

 ???

Source Editor

 ???

Toolbox

 ???

FindDialog

 ???

References

 ???


How to use the Jabaco Debugger

Image:DebugDescSample.png


How to use the 'Jabaco.xml' in Project-Folder

As discussed at the community forum, you are able to translate Jabaco to your native language, in the XML file format, encoded in UTF-8.

<xml>
<item name="Entry"></item>
</xml>

Related

???

Retrieved from "http://www.jabaco.org/wiki/Jabaco_IDE_Description"

This page has been accessed 8,577 times. This page was last modified on 8 June 2012, at 18:09.


This page has been accessed 8,577 times. This page was last modified on 8 June 2012, at 18:09.