You are not logged in.

Dear visitor, welcome to Jabaco - Community. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Dani

Intermediate

  • "Dani" started this thread

Posts: 263

Date of registration: Nov 19th 2009

Location: GERMANY

  • Send private message

1

Monday, March 12th 2012, 12:15pm

ComboBox1.ListIndex - can not be set to 0 or -1

Hey everybody,

Jabaco Source

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
Public Sub Form_Load()

   ComboBox1.AddItem 0
   ComboBox1.AddItem 1
   
   ComboBox1.ListIndex = 1
   Debug.Print ComboBox1.ListIndex 
   
   'will not change ListIndex!!
   ComboBox1.ListIndex = 0
   Debug.Print ComboBox1.ListIndex 
   
   'will not change ListIndex!!
   ComboBox1.ListIndex = -1
   Debug.Print ComboBox1.ListIndex 

End Sub


I am not sure if this was happening before!?
But with framework rev87 I can not set the ComboBox1.ListIndex to 0 or -1!!

Dani

Dani

Intermediate

  • "Dani" started this thread

Posts: 263

Date of registration: Nov 19th 2009

Location: GERMANY

  • Send private message

2

Wednesday, March 14th 2012, 6:36pm

Hey there,

in the framework...

Jabaco Source

1
2
3
4
5
Public Property Let ListIndex(val As Integer)
   If val > 0 And val < ListCount Then
      Call Parent.setSelectedIndex(val)
   End If
End Property


could be changed to something like this:

Jabaco Source

1
2
3
4
5
Public Property Let ListIndex(val As Integer)
   If val >= -1 And val < ListCount Then
      Call Parent.setSelectedIndex(val)
   End If
End Property


I am pretty sure this would be close to VB6 behaviour!!


Dani

fomaxrge

Trainee

Posts: 88

Date of registration: Aug 14th 2012

  • Send private message

3

Thursday, August 23rd 2012, 10:13am

Hello again Dani.

I am new user of Jabaco and i am a lit bit confused.
I have to download only the latest framework?
It is something like update?
I do not need the older frameworks?
About listindex-1 is it on the last framework?

Thank you for your precious help!

Rate this thread
WoltLab Burning Board